1. 程式人生 > >POJ 1836 Alignment

POJ 1836 Alignment

precision rate contain tin content win type ont include

鏈接:http://poj.org/problem?

id=1836

Alignment
Time Limit: 1000MS Memory Limit: 30000K Total Submissions: 14457 Accepted: 4690

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line‘s extremity (left or right). A soldier see an extremity if there isn‘t any soldiers with a higher or equal height than his height between him and that extremity.

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.


Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).

There are some restrictions:
? 2 <= n <= 1000
? the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

Source
Romania OI 2002

大意——從隊伍中抽取一些人,使得留下的每一個人至少能從一邊看到盡頭。問:給定一個數n,表示隊伍的長度,又已知隊員的各自身高。求抽走的最小人數滿足以上條件。

思路——問題轉化為求一列數從中間到兩端嚴格遞減的最長數目。

那麽我們能夠分別求出這列數從左到右和從右到左的最長遞增子序列。然後得到從中間到兩端遞減的最長序列所以此與POJ 2533類似。結果即為n減去這個最長序列的長度。

復雜度分析——時間復雜度:O(n^2),空間復雜度:O(n)

附上AC代碼:


#include <iostream>
#include <cstdio>
#include <string>
#include <cmath>
#include <iomanip>
#include <ctime>
#include <climits>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>
#include <set>
#include <map>
using namespace std;
typedef unsigned int UI;
typedef long long LL;
typedef unsigned long long ULL;
typedef long double LD;
const double pi = acos(-1.0);
const double e = exp(1.0);
const int maxn = 1005;
int prev[maxn], next[maxn]; // 分別代表從左、右邊開始的LIS長度
double high[maxn]; // 士兵的身高

int main()
{
	ios::sync_with_stdio(false);
	int n;
	while (scanf("%d", &n) != EOF)
	{
		for (int i=0; i<n; i++)
			scanf("%lf", &high[i]);
		prev[0] = next[n-1] = 1;
		for (int i=1; i<n; i++)
		{ // 從左邊求LIS長度
			prev[i] = 1;
			for (int j=0; j<i; j++)
				if (high[j] < high[i])
					prev[i] = max(prev[i], prev[j]+1);
		}
		for (int i=n-2; i>=0; i--)
		{ // 從右邊求LIS長度
			next[i] = 1;
			for (int j=n-1; j>i; j--)
				if (high[j] < high[i])
					next[i] = max(next[i], next[j]+1);
		}
		int ans = 0;
		for (int i=0; i<n-1; i++)
			for (int j=i+1; j<n; j++)
				ans = max(ans, prev[i]+next[j]);
		printf("%d\n", n-ans);
	}
	return 0;
}


POJ 1836 Alignment