1. 程式人生 > >[poj 1836] Alignment dp

[poj 1836] Alignment dp

floating val program nging cstring number name digits any

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line‘s extremity (left or right). A soldier see an extremity if there isn‘t any soldiers with a higher or equal height than his height between him and that extremity.


Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line.

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n).


There are some restrictions:
? 2 <= n <= 1000
? the height are floating numbers from the interval [0.5, 2.5]

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

題意是讓抽出一些士兵 使剩下的士兵成三角分布
先從左到右求最長單調遞減子序列 再從右向左求最長單調遞減子序列
然後枚舉起始點 有兩個 n-l_dp[i]-r_dp[j] 即為需要去除的最小人數
#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;

int n;
double a[1010];
int r_dp[1010];
int l_dp[1010];

void Rsub()
{
    for (int i = n; i >= 1; i--) {
        r_dp[i] = 1;
        for (int j = n; j > i; j--) {
            if (a[i] > a[j])
                r_dp[i] = max(r_dp[i], r_dp[j]+1);
        }
    }
}

void Lsub()
{
    for (int i = 1; i <= n; i++) {
        l_dp[i] = 1;
        for (int j = 1; j < i; j++) {
            if (a[i] > a[j])
                l_dp[i] = max(l_dp[i], l_dp[j]+1);
        }
    }
}

int main()
{
    //freopen("1.txt", "r", stdin);
    scanf("%d", &n);
    for (int i = 1; i <= n; i++) {
        scanf("%lf", &a[i]);
    }
    Rsub();
    Lsub();
    int ans = 1100;
    for (int i = 1; i <= n; i++) {
        for (int j = i+1; j <= n; j++)
            ans = min(ans, n-l_dp[i]-r_dp[j]);
    }
    printf("%d\n", ans);

    

    return 0;
}

 

[poj 1836] Alignment dp