1. 程式人生 > >POJ 2586 Y2K Accounting Bug(枚舉大水題)

POJ 2586 Y2K Accounting Bug(枚舉大水題)

lin uri ssd 數據丟失 span com reported cpp rem

Y2K Accounting Bug
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10674 Accepted: 5344

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit
看了兩遍。不知道題意是什麽。。

。。借鑒了一下:

題意: 有一個公司因為某個病毒使公司贏虧數據丟失,但該公司每月的 贏虧是一個定數,要麽一個月贏利s,要麽一月虧d。

如今ACM僅僅知道該公司每五個月有一個贏虧報表。並且每次報表贏利情況都為虧。

在一年中這種報表總共同擁有8次(1到5,2到6,…,8到12),如今要編一個程序確定當贏s和虧d給出。並滿足每張報表為虧的情況下,全年公司最高可贏利多少,若存在。則輸出多多額,若不存在,輸出"Deficit"。


分析: 在保證連續5個月都虧損的前提下。使得每5個月中虧損的月數最少。

x=1: ssssd,ssssd,ss d>4s 贏利10個月 10s-2d
x=2: sssdd,sssdd,ss 2d>3s 贏利8個月 8s-4d
x=3: ssddd,ssddd,ss 3d>2s 贏利6個月 6s-6d
x=4: sdddd,sdddd,sd 4d>s 贏利3個月 3s-9d
x=5: ddddd,ddddd,dd 4d<s 無贏利
除了分類,枚舉也能夠,12個月。每一個月兩種情況。。

O(2^12)

代碼例如以下:
#include <iostream>
using namespace std;

int main()
{
	int s,d;
	int res;
	while(cin>>s && cin>>d)
	{
		if(d>4*s)res=10*s-2*d;
		else if(2*d>3*s)res=8*s-4*d;
		else if(3*d>2*s)res=6*(s-d);
		else if(4*d>s)res=3*(s-3*d);
		else res=-1;
		if(res<0)cout<<"Deficit"<<endl;
		else cout<<res<<endl;
	}
	return 0;
}

POJ 2586 Y2K Accounting Bug(枚舉大水題)