1. 程式人生 > >Wall Painting HDU - 4810(組合數異或和)

Wall Painting HDU - 4810(組合數異或和)

Ms.Fang loves painting very much. She paints GFW(Great Funny Wall) every day. Every day before painting, she produces a wonderful color of pigments by mixing water and some bags of pigments. On the K-th day, she will select K specific bags of pigments and mix them to get a color of pigments which she will use that day. When she mixes a bag of pigments with color A and a bag of pigments with color B, she will get pigments with color A xor B. 
When she mixes two bags of pigments with the same color, she will get color zero for some strange reasons. Now, her husband Mr.Fang has no idea about which K bags of pigments Ms.Fang will select on the K-th day. He wonders the sum of the colors Ms.Fang will get with 

 different plans. 

For example, assume n = 3, K = 2 and three bags of pigments with color 2, 1, 2. She can get color 3, 3, 0 with 3 different plans. In this instance, the answer Mr.Fang wants to get on the second day is 3 + 3 + 0 = 6. 
Mr.Fang is so busy that he doesn’t want to spend too much time on it. Can you help him? 
You should tell Mr.Fang the answer from the first day to the n-th day.

Input

There are several test cases, please process till EOF. 
For each test case, the first line contains a single integer N(1 <= N <= 10 3).The second line contains N integers. The i-th integer represents the color of the pigments in the i-th bag.

Output

For each test case, output N integers in a line representing the answers(mod 10 6 +3) from the first day to the n-th day.

Sample Input

4
1 2 10 1

Sample Output

14 36 30 8

 

 求出 i 個數異或和。i 個數的組合很多,所以異或跟1的個數有關係。

先把每一位的二進位制位1的個數求一下,在用排列組合的方式求出奇數個1的組合方式。

#include<bits/stdc++.h>
using namespace std;
const int maxn=1010;
const int mod=1e6+3;
typedef long long ll;
ll sum[maxn];
ll a[maxn];
int x[maxn];
int n;

ll c[maxn][maxn];
void C()
{
    memset(c,0,sizeof(c));
    for(int i=0;i<=n;i++)
    {
        c[i][0]=1;
        for(int j=1;j<=i;j++)
        {
            c[i][j]=(c[i-1][j-1]+c[i-1][j])%mod;
        }
    }
}
void geta(ll aa)
{
    int xx=0;
    while(aa)
    {
        if(aa%2) x[xx]++;
        aa/=2;
        xx++;
    }
    return ;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        scanf("%lld",&a[i]);
        memset(sum,0,sizeof(sum));
        memset(x,0,sizeof(x));
        for(int i=1;i<=n;i++)
        {
            geta(a[i]);
        }
        C();
        for(int i=1;i<=n;i++)
        {
            for(int j=0;j<32;j++)
            {
                for(int v=1;v<=i;v+=2)
                {
                    sum[i]=(sum[i]+(((c[x[j]][v]*c[n-x[j]][i-v])%mod)*(1<<j))%mod)%mod;
                }
            }
        }
        for(int i=1;i<n;i++)
            printf("%lld ",(sum[i]+mod)%mod);
        printf("%lld\n",(sum[n]+mod)%mod);
    }
}