1. 程式人生 > >杭電1224(Floyd最長路+輸出路徑)

杭電1224(Floyd最長路+輸出路徑)

Free DIY Tour

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It’s a good chance to relax themselves. To most of them, it’s the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company’s statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

Input

The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

Output

For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.

Output a blank line between two cases.

Sample Input

2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4

Sample Output

CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1

思路:

題意:自定義旅遊,每個城市 n 有不同的興趣指數,起始城市 0 和終點城市 n+1為同一個且興趣指數為0,在標號大的城市沒有飛往標號小的城市的飛機(即單向圖),求出最大的興趣指數並輸出路徑。

方法:Floyd演算法求最長路徑。

注意:求最長路時,INF初始值為 -0xfffffff 。

AC程式碼:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 105
#define INF -0xfffffff //-的
int n,m;
int city[maxn];//記錄城市的好玩程度 
int fun[maxn][maxn];//以連通邊形式記錄好玩程度 
int path[maxn][maxn];//記錄路徑 

void init()
{
    city[n]=0;//初始化第n+1個城市為起始城市且好玩程度為0 
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            if(i==j) fun[i][j]=0;
            else fun[i][j]=INF;
            path[i][j]=j;// 
        }
    }
}

void floyd()
{
    for(int k=1;k<=n;k++)
    {
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(fun[i][j]<fun[i][k]+fun[k][j])
                {
                    fun[i][j]=fun[i][k]+fun[k][j];
                    path[i][j]=path[i][k];//
                }
            }
        }
    }
}

int main()
{
    int t,u,v;//t case,城市u->v
    int icase=0;//記錄case 
    cin>>t;
    while(t--)
    {
        cin>>n;//n個城市 
        n++;//第n+1個城市也為起始城市 
        init();
        for(int i=1;i<n;i++)
        {
            cin>>city[i];//輸入城市有趣程度 
        } 
        cin>>m;//m對城市連通情況 
        for(int i=0;i<m;i++)
        {
            cin>>u>>v;
            fun[u][v]=city[v];//u->v有趣程度為v的有趣程度 
        }
        floyd();
        cout<<"CASE "<<++icase<<"#"<<endl;
        cout<<"points : "<<fun[1][n]<<endl;
        cout<<"circuit : 1";
        //輸出路徑資訊 
        int i=1;
        while(i!=n)
        {
            if(path[i][n]==n) cout<<"->"<<1;
            else cout<<"->"<<path[i][n];
            i=path[i][n];
        }
        cout<<endl; 
        if(t!=0) cout<<endl;//兩個輸出間要有空行 
    }
    return 0;
}