1. 程式人生 > >HDU 1159:Common Subsequence(最長公共子序列)

HDU 1159:Common Subsequence(最長公共子序列)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23108    Accepted Submission(s): 10149


Problem Description A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input abcfbc abfcab programming contest abcd mnp
Sample Output 4 2 0

當 i = 0 , j = 0 時 , dp[i][j] = 0


當 i , j > 0 ; xi = yi 時 ,dp[i][j] = dp[i-1][j-1] + 1
當 i , j > 0 ; xi != yi 時 ,dp[i][j] = max { dp[i][j-1] , dp[i-1][j] }



#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<stdlib.h>
#include<vector>
#include<queue>
#include<cmath>

using namespace std;

char str1[1005];
char str2[1005];
int dp[1005][1005];

int main()
{
    while(scanf("%s %s",str1+1,str2+1)!=EOF)
    {
        memset(dp, 0, sizeof(dp));
        int len1=strlen(str1+1);
        int len2=strlen(str2+1);

        for(int i=1; i<=len1; i++)
            for(int j=1; j<=len2; j++)
            {
                if(str1[i]==str2[j])
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);

            }
        cout<<dp[len1][len2]<<endl;

    }
    return 0;
}