1. 程式人生 > >1057 Stack (30 分)樹狀陣列求堆疊中位數

1057 Stack (30 分)樹狀陣列求堆疊中位數

題目

Stack is one of the most fundamental data structures, which is based on the principle of Last In First Out (LIFO). The basic operations include Push (inserting an element onto the top position) and Pop (deleting the top element). Now you are supposed to implement a stack with an extra operation: PeekMedian – return the median value of all the elements in the stack. With N elements, the median value is defined to be the (N/2)-th smallest element if N is even, or ((N+1)/2)-th if N is odd.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N ( 1 0

5 ) N (≤10^5) . Then N lines follow, each contains a command in one of the following 3 formats:

Push key
Pop
PeekMedian

where key is a positive integer no more than 1

0 5 10^5 .

Output Specification:
For each Push command, insert key into the stack and output nothing. For each Pop or PeekMedian command, print in a line the corresponding returned value. If the command is invalid, print Invalid instead.

Sample Input:

17
Pop
PeekMedian
Push 3
PeekMedian
Push 2
PeekMedian
Push 1
PeekMedian
Pop
Pop
Push 5
Push 4
PeekMedian
Pop
Pop
Pop
Pop

Sample Output:

Invalid
Invalid
3
2
2
1
2
4
4
5
3
Invalid

解題思路

  題目大意: 給你一個堆疊,有3種指令,第一個指令Pop,即出棧,第二個指令 Push key,即壓棧,第三個指令,PeekMedian 查詢堆疊中位數。
  解題思路: 這道題的難點如何確定中位數,如果對堆疊做排序,肯定會超時的。這裡介紹一種樹狀陣列的方法,詳情見程式碼——


#include<stdio.h>
#include<string.h>
#include<stack>
#include<algorithm>
using namespace std;
 
const int maxn = 100001;
int c[maxn] = {0};
 
int lowbit(int n){
	return n & (-n);
} 
 
void update(int i,int val){
	while(i <= maxn){
		c[i] += val;
		i += lowbit(i);
	}
} 
 
int getsum(int i){
	int sum = 0;
	while(i > 0){
		sum += c[i];
		i -= lowbit(i);
	}
	return sum;
}
 
int Bsearch(int num){
	int l = 0,r = maxn-1,mid;
	while(l < r){
		mid = (l + r) / 2;
		int n = getsum(mid);
		//注意這裡不能用n == num並返回mid,因為樹狀陣列的c[i]是塊狀之和,部分sum[i]的值可能一樣 
		//所以必須是一直向左移動獲得最少的sum[i]下標 
		if(n >= num)
			r = mid;
		else
			l = mid + 1;
	}
	return r;
}
 
 
int main(){
	int n;
	scanf("%d",&n);
	char ch[11] = {0};
	stack<int> s;
	for(int i=0;i<n;i++)
	{
		scanf("%s",ch);
		if(ch[1] == 'e'){
			if(s.size() == 0)
				printf("Invalid\n");
			else{
				int num = s.size();
				if(num%2 == 0)
					num = num / 2;
				else
					num = (num+1) / 2;
				printf("%d\n",Bsearch(num));
			}
		}
		else if(ch[1] == 'o'){
			if(s.size() == 0)
				printf("Invalid\n");
			else{
				printf("%d\n",s.top());
				update(s.top(),-1);
				s.pop();
			}
		}
		else{
			int a;
			scanf("%d",&a);
			s.push(a);
			update(s.top(),1);
		}
	}
	
	return 0;
}

在這裡插入圖片描述

題目

  哀吾生之須臾,羨長江之無窮。這道題完全不會做,挺難的。