1. 程式人生 > >1048 Find Coins (25 分)【Hash雜湊】

1048 Find Coins (25 分)【Hash雜湊】

1048 Find Coins (25 分)
Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10
​5
​​  coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10
​5
​​ , the total number of coins) and M (≤10
​3
​​ , the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the two face values V
​1
​​  and V
​2
​​  (separated by a space) such that V
​1
​​ +V
​2
​​ =M and V
​1
​​ ≤V
​2
​​ . If such a solution is not unique, output the one with the smallest V
​1
​​ . If there is no solution, output No Solution instead.

Sample Input 1:
8 15
1 2 8 7 2 4 11 15
Sample Output 1:
4 11
Sample Input 2:
7 14
1 8 7 2 4 11 15
Sample Output 2:
No Solution


解題思路:我一開始就是直接模擬,用矩陣上三角形的想法做的,符合了就直接return 0;但是有2個測試點過不了,執行超時,然後參考了柳婼學姐的,用hash雜湊來做

//執行超時
#include<bits/stdc++.h>
using namespace std;
int v[1001];
int main(void)
{
    int n,value,a;
    scanf("%d %d",&n,&value);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a);
        v[a]++;
    }
    for(int i=0;i<1001;i++)
    {
        if(v[i])
        {
            v[i]--;
            if(i<value&&v[value-i])
            {
                printf("%d %d\n",i,value-i);
                return 0;
            }
            v[i]++;
        }
    }
    printf("No Solution\n");
    return 0;
}


參考柳婼學姐
https://github.com/liuchuo/PAT/blob/master/AdvancedLevel_C%2B%2B/1048.%20Find%20Coins%20(25).cpp#L1

//正確的
#include<bits/stdc++.h>
using namespace std;
int v[1001];
int main(void)
{
    int n,value,a;
    scanf("%d %d",&n,&value);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a);
        v[a]++;
    }
    for(int i=0;i<1001;i++)
    {
        if(v[i])
        {
            v[i]--;
            if(i<value&&v[value-i])
            {
                printf("%d %d\n",i,value-i);
                return 0;
            }
            v[i]++;
        }
    }
    printf("No Solution\n");
    return 0;
}