1. 程式人生 > >1028 List Sorting (25 分)【簡單排序】

1028 List Sorting (25 分)【簡單排序】

1028 List Sorting (25 分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

解題思路:這題沒什麼難點,只要注意資料輸入輸出用scanf,不要用cin就行,最後一個測試點會過不了,執行超時 

#include<bits/stdc++.h>
using namespace std;
struct Node{
	int id,grade;
	char name[10];
}node[100001];
int cmp1(Node a,Node b)
{
     return a.id<b.id;
}
int cmp2(Node a,Node b)
{
	if(strcmp(a.name,b.name)==0 )return a.id<b.id;
	return strcmp(a.name,b.name)<=0;
}
int cmp3(Node a,Node b)
{
	if(a.grade==b.grade) return a.id<b.id;
	return a.grade<b.grade;
}
int main(void)
{
    int n,c;
    scanf("%d %d",&n,&c);
    for(int i=0;i<n;i++)
    {
    	scanf("%d %s %d",&node[i].id,node[i].name,&node[i].grade);
    //	cin>>node[i].id>>node[i].name>>node[i].grade;
	}
	if(c==1) sort(node,node+n,cmp1);
	else if(c==2) sort(node,node+n,cmp2);
	else if(c==3) sort(node,node+n,cmp3);
	for(int i=0;i<n;i++)
	{
		printf("%06d %s %d\n",node[i].id,node[i].name,node[i].grade);
    	//cout<<" "<<node[i].name<<" "<<node[i].grade<<endl;
	}

    return 0;
}