1. 程式人生 > >【二分圖匹配入門專題1】F - COURSES poj1469【最大匹配--匈牙利算法模板題】

【二分圖匹配入門專題1】F - COURSES poj1469【最大匹配--匈牙利算法模板題】

nbsp possible count dfs positive owin not hat first

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
  • each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student 1 1 Student 1 2 ... Student 1 Count1
Count2 Student 2 1
Student 2 2 ... Student 2 Count2
...
CountP Student P 1 Student P 2 ... Student P CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

題意:輸入p門課和n個學生,共1-p行,每行先輸入學生總數n,再輸入學生編號,問,能否滿足,每個學生只選一門課,每門課有一個學生。
思路:又是最大匹配的水題,我很懷疑學長這次是先把各個oj上的水題放到前10道,然後後面的就6到飛起的那種
#include<stdio.h>
#include<string.h>
#define N 330
#define M 330
int e[N][M],book[M],match[M];
int n,m;
int dfs(int u)
{
    int i;
    for(i = 1; i <= m; i ++)
    {
        if(!book[i]&&e[u][i])
        {
            book[i] = 1;
            if(!match[i]||dfs(match[i]))
            {
                match[i] = u;
                return 1;
            }
        }
    }
    return 0;
}

int main()
{
    int i,j,t2,sum,t;
    scanf("%d",&t);
    while(t--)
    {
        memset(match,0,sizeof(match));
        memset(e,0,sizeof(e));
        scanf("%d%d",&n,&m);
        for(i = 1; i <= n; i ++)
        {
            scanf("%d",&sum);
            for(j = 1;j <= sum; j ++)
            {
                scanf("%d",&t2);
                e[i][t2] = 1;
            }
        }
        sum = 0;
        for(i = 1; i <= n; i ++)
        {
            memset(book,0,sizeof(book));
            if(dfs(i))
                sum ++;
        }
        if( sum == n)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

【二分圖匹配入門專題1】F - COURSES poj1469【最大匹配--匈牙利算法模板題】