1. 程式人生 > >POJ1469 COURSES 【二分圖最大匹配·HK算法】

POJ1469 COURSES 【二分圖最大匹配·HK算法】

pri number break integer iss pre win rop find

COURSES
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17777 Accepted: 7007

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
  • each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1
Student2 2 ... Student2 Count2
...
CountP StudentP 1 StudentP 2 ... StudentP CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses ?from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

Source

Southeastern Europe 2000

題意:有P門課,N個學生,每門課僅僅能相應一個人,可是單個人能夠相應多門課。求最大匹配是否等於P。

題解:匈牙利也能夠解,看到書上介紹了這個HK算法,時間復雜度要更低,於是嘗試了下,可是...寫起來真是太麻煩了。


#include <stdio.h>
#include <string.h>
#include <queue>

#define maxn 305
#define maxp 105
#define maxm maxn * maxp
#define inf 0x3f3f3f3f

int head[maxp], id, p, n, dis;
struct Node {
    int v, next;
} E[maxm];
int dx[maxp], dy[maxn], cx[maxp], cy[maxn];
bool visy[maxn];

void AddEdge(int u, int v) {
    E[id].v = v; 
    E[id].next = head[u];
    head[u] = id++;
}

void GetMap() {
    int k, v, i; id = 0;
    scanf("%d%d", &p, &n);
    memset(head, -1, sizeof(int) * (p + 1));
    for(i = 1; i <= p; ++i) {
        scanf("%d", &k);
        while(k--) {
            scanf("%d", &v);
            AddEdge(i, v);
        }
    }
}

bool searchPath() {
    std::queue<int> Q;
    int i, u, v; dis = inf;
    memset(dx, 0, sizeof(int) * (p + 1));
    memset(dy, 0, sizeof(int) * (n + 1));
    for(i = 1; i <= p; ++i) {
        if(!cx[i]) Q.push(i);
    }
    while(!Q.empty()) {
        u = Q.front(); Q.pop();
        if(dx[u] > dis) break;
        for(i = head[u]; i != -1; i = E[i].next) {
            if(!dy[v = E[i].v]) {
                dy[v] = dx[u] + 1;
                if(!cy[v]) dis = dy[v];
                else {
                    dx[cy[v]] = dy[v] + 1;
                    Q.push(cy[v]);
                }
            }
        }
    }
    return dis != inf;
}

int findPath(int u) {
    int i, v;
    for(i = head[u]; i != -1; i = E[i].next) {
        if(!visy[v = E[i].v] && dx[u] + 1 == dy[v]) {
            visy[v] = 1;
            if(dy[v] == dis && cy[v]) continue;
            if(!cy[v] || findPath(cy[v])) {
                cy[v] = u; cx[u] = v;
                return 1;
            }
        }
    }
    return 0;
}

int MaxMatch() {
    int ans = 0, i;
    memset(cx, 0, sizeof(int) * (p + 1));
    memset(cy, 0, sizeof(int) * (n + 1));
    while(searchPath()) {
        memset(visy, 0, sizeof(bool) * (n + 1));
        for(i = 1; i <= p; ++i)
            if(!cx[i]) ans += findPath(i);
    }
    return ans;
}

void Solve() {
    printf(MaxMatch() == p ? "YES\n" : "NO\n");
}

int main() {
    // freopen("stdin.txt", "r", stdin);
    int t;
    scanf("%d", &t);
    while(t--) {
        GetMap();
        Solve();
    }
    return 0;
}


POJ1469 COURSES 【二分圖最大匹配&#183;HK算法】