1. 程式人生 > >poj 1273 Drainage Ditches(最大流)

poj 1273 Drainage Ditches(最大流)

for from cstring ref farm info pat fun instead

poj 1273 Drainage Ditches

對增廣路,最大流不知太熟悉,看這裏

Description
Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

題目大意:給出圖,求最大流。

解題思路:註意。同一條路可能出現多次,所以統計容量的時候不要“C[i][j] = c” 要 “C[i][j] += c”。

EK算法

#include <cstdio>
#include <cstring>
#include <algorithm> #include <cmath> #include <cstdlib> #include <queue> using namespace std; typedef long long ll; const int N = 205; const int INF = 0x3f3f3f3f; int n, m; int C[N][N], F[N][N]; void Input() { memset(C, 0, sizeof(C)); memset(F, 0, sizeof(F)); int a, b, c; for (int i = 0; i < m; i++) { scanf("%d %d %d", &a, &b, &c); C[a][b] += c; } } int EK() { queue<int> Q; int a[N], pre[N], ans = 0; while (1) { memset(pre, 0, sizeof(pre)); memset(a, 0, sizeof(a)); a[1] = INF; Q.push(1); while (!Q.empty()) { int u = Q.front(); Q.pop(); for (int v = 0; v <= n; v++) { if (!a[v] && C[u][v] > F[u][v]) { pre[v] = u; Q.push(v); a[v] = min(a[u], C[u][v] - F[u][v]); } } } if (a[n] == 0) break; ans += a[n]; for (int u = n; u != 1; u = pre[u]) { F[pre[u]][u] += a[n]; F[u][pre[u]] -= a[n]; } } return ans; } int main() { while (scanf("%d %d", &m, &n) == 2) { Input(); printf("%d\n", EK()); } return 0; }

Dinic算法

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <queue>
const int N = 1005;
const int INF = 0x3f3f3f3f;
using namespace std;
typedef long long ll;
int n, m, s, t;
struct Edge{
    int from, to, cap, flow;
};
vector<Edge> edges;
vector<int> G[N];
void init() {
    for (int i = 0; i < n; i++) G[i].clear();
    edges.clear();
}
void addEdge(int from, int to, int cap, int flow) {
    edges.push_back((Edge){from, to, cap, 0});
    edges.push_back((Edge){to, from, 0, 0});
    int m = edges.size();
    G[from].push_back(m - 2);
    G[to].push_back(m - 1);
}
void input() {
    int u, v, c;
    for (int i = 0; i < m; i++) {
        scanf("%d %d %d", &u, &v, &c);  
        addEdge(u, v, c, 0);
    }   
}
int vis[N], d[N];
int BFS() {
    memset(vis, 0, sizeof(vis));
    for (int i = 0; i < n; i++) d[N] = INF;
    queue<int> Q;
    Q.push(s);
    d[s] = 0;
    vis[s] = 1;
    while (!Q.empty()) {
        int u = Q.front(); Q.pop(); 
        for (int i = 0; i < G[u].size(); i++) {
            Edge &e = edges[G[u][i]];   
            if (!vis[e.to] && e.cap > e.flow) {
                vis[e.to] = 1;  
                d[e.to] = d[u] + 1;
                Q.push(e.to);
            }
        }
    }
    return vis[t];
}
int cur[N];
int DFS(int u, int a) {
    if (u == t || a == 0) return a;
    int flow = 0, f; 
    for (int &i = cur[u]; i < G[u].size(); i++) {
        Edge &e = edges[G[u][i]];
        if (d[u] + 1 == d[e.to] && (f = DFS(e.to, min(a, e.cap - e.flow))) > 0) {
        e.flow += f;    
        edges[G[u][i]^1].flow -= f;
        flow += f;
        a -= f;
        if (a == 0) break;
        }
    }
    return flow;
}
int MF() {
    int ans = 0;
    while (BFS()) {
        memset(cur, 0, sizeof(cur));    
        ans += DFS(s, INF);
    }
    return ans;
}
int main() {
    while (scanf("%d %d", &m, &n) == 2) {
        s = 1, t = n;
        init();         
        input();
        printf("%d\n", MF());
    }
    return 0;
}

poj 1273 Drainage Ditches(最大流)