1. 程式人生 > >HDU 1237 簡單計算器 表示式求值

HDU 1237 簡單計算器 表示式求值

簡單計算器

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12466    Accepted Submission(s): 4098


Problem Description 讀入一個只包含 +, -, *, / 的非負整數計算表示式,計算該表示式的值。

Input 測試輸入包含若干測試用例,每個測試用例佔一行,每行不超過200個字元,整數和運算子之間用一個空格分隔。沒有非法表示式。當一行中只有0時輸入結束,相應的結果不要輸出。

Output 對每個測試用例輸出1行,即該表示式的值,精確到小數點後2位。

Sample Input 1 + 2 4 + 2 * 5 - 7 / 11 0
Sample Output 3.00 13.36
/*
HDU 1237 表示式求值
現將下表達式求值的思想:
1.將中綴表示式轉為字尾表示式
	設定兩個棧,一個用來儲存字尾式的棧,一個用來暫時儲存運算子的棧,
將中序表示式一個一個字元地讀入,遇到數字字元就直接壓入字尾式棧,
遇到運算子時就先暫時儲存到運算子棧中,
等到下次讀到字元時將運算子棧中的運算子與之比較優先順序,
若運算子棧裡的運算子的優先順序高於這次讀到的運算子就將運算子棧中的運算子進棧,
否則將這個運算子壓入運算子棧。
4 + 2 * 5 - 7 / 11
425*711/-+
2.字尾表示式求值
	遇到字元是個操作符,彈出2個運算元,運算完結果壓入 
	
或者運算子棧裡的優先順序高 直接彈出2個數計算 後再壓入
425	 遇到-	          14 7 11	   14 0.636        
+*   ==>*計算 +計算    -/      ==>   -       ==> 13.36  
*/ 
#include<iostream>
#include<stdio.h>
#include<stack>
#include<cstring>
using namespace std;
char str[205]; 

int change(char c)  
{  
    if(c=='+')      return 1;  
    if(c=='-')      return 2;  
    if(c=='*')      return 3;  
    if(c=='/')      return 4;  
    return -1;  
}  

int cmp(int a,int b)  
{  
    if(a==1||a==2)  a=1;  
    else a=2;  
    if(b==1||b==2)  b=1;  
    else b=2;  
    
    if(a>=b)  
        return 1;  
    return 0;  
  
}  
void cal()
{
	stack<double>a;  //字尾結果棧 
    stack<int>b; // 運算子棧  
    int i,len=strlen(str);
	double s;
	 
    for(i=0;i<len;i++)  
    {  
        if(str[i]==' ')  
            continue;  
        if(str[i]>='0'&&str[i]<='9') //數字 
        {  
            s=0;  
            while(str[i]>='0'&&str[i]<='9')  
            {  
                s=s*10+str[i]-'0';  
                i++;  
            }  
            a.push(s); 
        }  
        if(str[i]=='+'||str[i]=='-'||str[i]=='*'||str[i]=='/')  
        {  
            int temp;  
            temp=change(str[i]);  
            if(b.empty())  
            {  
                b.push(temp);  
                continue;  
            }  
            else  
            {  
                int t=b.top();//運算子棧裡的優先順序大於當前的,將運算子棧裡的壓入到字尾  
                while(cmp(t,temp))             
                {     
					double a1=a.top(); a.pop();  //彈出2個運算元 
                    double b1=a.top(); a.pop();  
                    
                    int c=b.top(); b.pop();//彈出運算子棧裡的運算子  
                      
                    switch(c)
					{
                    	case 1:   
                        	a.push(a1+b1);
							break;
						case 2:  
                        	a.push(b1-a1); 
                        	break;
						case 3: 
                        	a.push(a1*b1);
                        	break;
						case 4:   
                        	a.push(b1/a1);
							break;
                    }
                    
                    if(b.empty()) //如果這樣寫要判斷為空否  
                        break;  
                    else  		  //否則繼續比較運算子棧頂運算 
                    	t=b.top();  
          
                }  
                b.push(temp); // 將這個運算子壓入運算子棧    
            }  
              
        }  
    }  
    while(!b.empty())  
    {  
        double a1=a.top(); a.pop();  //彈出2個運算元 
        double b1=a.top(); a.pop();  
                    
        int c=b.top(); b.pop();//彈出運算子棧裡的運算子  
                      
        switch(c)
		{
            case 1:   
           		a.push(a1+b1);
				break;
			case 2:  
                a.push(b1-a1); 
                break;
			case 3: 
                a.push(a1*b1);
                break;
			case 4:   
                a.push(b1/a1);
				break;
        } 
    }  
    printf("%.2lf\n",a.top());    
}

int main()
{
	while(gets(str),strcmp(str,"0"))
	{
		cal();
	}
	return 0;
}