1. 程式人生 > >poj1502MPI Maelstrom(Dijkstra等等最短路的入門題)

poj1502MPI Maelstrom(Dijkstra等等最短路的入門題)

                                                                                           MPI Maelstrom
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4663 Accepted: 2831

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee's research advisor, Jack Swigert, has asked her to benchmark the new system.
``Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert. ``Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.''

``How is Apollo's port of the Message Passing Interface (MPI) working out?'' Swigert asked.

``Not so well,'' Valentine replied. ``To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.''

``Is there anything you can do to fix that?''

``Yes,'' smiled Valentine. ``There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.''

``Ah, so you can do the broadcast as a binary tree!''

``Not really a binary tree -- there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5
50
30 5
100 20 50
10 x x 10

Sample Output

35
題目大意:這題目可真是長啊。但是關鍵的只有一部分``Not really a binary tree -- there are some particular features of our network that we should exploit. 
The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, 
the messages don't necessarily arrive at the destinations at the same time -- there is a communication cost involved. In general, we need to take into 
account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.''
說明了,每個處理器與其他處理器相連線,這裡的連線就是權值的大小。 所有的是:Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors. 從第一個處理器到其他所有處理器中所花時間最小的那個。那麼就是求1號處理器,到2,3,4.....n號處理器的最短距離的最大值就行了。 思路:用任意一種最短路演算法,求出1號節點到其他點的單源最短路,然後求出他們中的最大值。 注意輸入:由於是數字和字元混在一起,因此用char str[200]讀入,通過atoi轉化很方便。 程式碼如下:由於資料量很小,我用的裸的dijkstra,其實別小看這種裸題,有些人對這個演算法的層次結構還真不太清楚,然後貼上模版。。其實理解最原始的,然後一步一步優化
/**
   author:liuwen
*/
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <climits>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#include <algorithm>
using namespace std;
const int maxn=105;
const int inf=1000000;
int dist[maxn],G[maxn][maxn];
int n;
void initial_Map()
{
    memset(G,0,sizeof(G));
    memset(dist,0,sizeof(dist));
    for(int i=0;i<maxn;i++)
        for(int j=0;j<maxn;j++)
            G[i][j]=(i==j?0:inf);
}
void Dijkstra()
{
    int vis[maxn];
    int i,j,k,_min;
    memset(vis,0,sizeof(vis));
    for(i=0;i<n;i++){
        dist[i]=G[0][i];
    }
    dist[0]=0;
    vis[0]=1;
    for(i=1;i<n;i++){
        k=0,_min=INT_MAX;
        for(j=0;j<n;j++){
            if(!vis[j]&&_min>dist[j]){
                k=j;
                _min=dist[j];
            }
        }
        if(k==0)    return;
        vis[k]=1;
        for(j=0;j<n;j++){
            if(!vis[j]&&G[k][j]!=inf&&dist[j]>dist[k]+G[k][j]){
                dist[j]=dist[k]+G[k][j];
            }
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    char str[200];
    while(scanf("%d",&n)==1){
        initial_Map();
        for(int i=1;i<n;i++){
            for(int j=0;j<i;j++){
                scanf("%s",str);
                if(str[0]=='x') G[i][j]=inf;
                else  G[i][j]=G[j][i]=atoi(str);
            }
        }
        Dijkstra();
        int maxL=INT_MIN;
        for(int i=0;i<n;i++){
            maxL=max(maxL,dist[i]);
        }
        printf("%d\n",maxL);
    }
    return 0;
}