1. 程式人生 > >Perfect Pth Powers解題報告(張宇)

Perfect Pth Powers解題報告(張宇)

J - Perfect Pth Powers Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

We say that x is a perfect square if, for some integer b, x = b2. Similarly, x is a perfect cube if, for some integer b, x = b3. More generally, x is a perfect pth power if, for some integer b, x = bp
. Given an integer x you are to determine the largest p such that x is a perfect pth power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect pth power.

Sample Input

17
1073741824
25
0

Sample Output

1
30
2

題意:輸入一個數x,若為0則結束。否則,我們知道這個數x必定存在相應的a,b,使得x等於a的b次方;這樣的a,b有至少一對。你所要做的就是求出最大的b。

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
	long long n;     //int不能滿足要求了...
	while(scanf("%lld",&n)!=EOF)
	{
		if(n==0) break;
		long long  m;
		int i;
		int ans=1;
		if(n<0)       //n可能為為負數
		{	m=-n;i=3;}    //負數當然得要是某個負數的奇次冪咯
		else
		{	m=n;i=2;}
		double eps=1e-12;   //精度很重要的,不能太小
		double p;
		for(;i<=32;)
		{
			p=pow(m*1.0,1.0/i);    //pow(int,int)提交報錯....改為float
			if(fabs(int(p+eps)-p)<eps)    //x等於a的b次方,b是整數,a也要是整數哦.
				ans=i;
			if(n<0)
				i+=2;     //負數當然得要是某個負數的奇次冪咯
			else
				i++;  
		}
		printf("%d\n",ans);
	}
	return 0;
}


相關推薦

Perfect Pth Powers解題報告

J - Perfect Pth Powers Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u Description We say t

Gold Balanced Lineup解題報告浩盛倫

Farmer John's N cows (1 ≤ N ≤ 100,000) share many similarities. In fact, FJ has been able to narrow down the list of features shared by his cows to a list

[TJOI2017] DNA 解題報告 hash+二分

log h+ get www. signed targe 相差 ria type 題目鏈接:https://www.luogu.org/problemnew/show/P3763 題目大意: 給定原串S0,詢問S0有多少個子串和給定串S相差不到3個字母 題解: 我們

Codeforces 514C. Watto and Mechanism解題報告字典樹

test names cin 單詞 turn void can include 傳送門 傳送門 題意:給你一個字典和一些詢問,問你對於每個詢問的字符串必須更改一個字符,能否得到字典中的某一個單詞。 思路:先構造一顆字典樹,然後搜一遍就行了,要註意strlen不能每次都用,常

[JZOJ 5906] [NOIP2018模擬10.15] 傳送門 解題報告樹形DP

nor dos color 樹形dp getchar() 傳送門 noip 轉化 每一個 題目鏈接: https://jzoj.net/senior/#contest/show/2528/2 題目: 8102年,Normalgod在GLaDOS的幫助下,研制出了傳

[jzoj 5178] [NOIP2017提高組模擬6.28] So many prefix? 解題報告KMP+DP

題目連結: https://jzoj.net/senior/#main/show/5178 題目: 題解: 我們定義$f[pos]$表示以位置pos為字尾的字串對答案的貢獻,答案就是$\sum_{i=1}^{n} f[i]$ 考慮怎麼得到f陣列,我們有$f[i]=f[nxt[i]]+[i是偶數]

hdu1258---Sum It Up解題報告DFS入門

                                         &n

[JZOJ 5912] [NOIP2018模擬10.18] VanUSee 解題報告 KMP+博弈

題目連結: https://jzoj.net/senior/#contest/show/2530/2 題目:   眾所周知,cqf童鞋對哲學有著深入的理解和認識,並常常將哲學思想應用在實際生活中,例如鍛鍊摔角技術或者研究化(fa)學。  由於cqf童鞋哲學造詣太過高深,以至

[JZOJ 5852] [NOIP2018提高組模擬9.6] 相交 解題報告 倍增+LCA

題目連結: http://172.16.0.132/senior/#main/show/5852 題目: 題目大意: 多組詢問,每次詢問樹上兩條鏈是否相交 題解: 兩條鏈相交併且僅當某一條鏈的兩個端點的LCA在另一個端點上 對於每次詢問,我們分別處理出兩條鏈端點的LCA,通過倍增判斷是否存在

POJ 2406 Power Strings 解題報告雜湊

Power Strings Time Limit: 3000MS Memory Limit: 65536K Total Submissions: 32810 Accepted: 13670 Description Given two strings a and b

poj2502解題報告Dijskstra演算法

題目大意:在一個城市裡,分佈著若干條地鐵線路,每條地鐵線路有若干個站點,所有地鐵的速度均為40km/h。現在你知道了出發地和終點的座標,以及這些地鐵線路每個站點的座標,你的步行速度為10km/h,且你到了地鐵的任意一個站之後就剛好有地鐵出發。問你從出發點到終點最少需要多少時

杭電ACM hdu 2152 Fruit 解題報告母函式

Problem Description 轉眼到了收穫的季節,由於有TT的專業指導,Lele獲得了大豐收。特別是水果,Lele一共種了N種水果,有蘋果,梨子,香蕉,西瓜……不但味道好吃,樣子更是好看。 於是,很多人們慕名而來,找Lele買水果。 甚至連大名鼎鼎的HDU ACM

UVa 1451 Average 解題報告斜率優化

1451 - Average Time limit: 3.000 seconds A DNA sequence consists of four letters, A, C, G, and T. The GC-ratio of a DNA sequence is the

整數劃分解題報告DP方法

1.問題描述: 給定一個正整數N和K 1.> 將n劃分成若干正整數之和的劃分數。 2.> 將n劃分成k個正整數之和的劃分數。 3.> 將n劃分成最大數不超過k的劃分數。 4.> 將n劃分成若干奇正整數之和的劃分數。 5.> 將n劃分成若干不同整數之和的劃分數。2.問題分

NOIP2014 無線網路發射器選址 解題報告水題

線上評測: http://codevs.cn/problem/3578/ 整體思路: 他怎麼說,你就怎麼做,不要在意n^2*m^2一樣能過, 失誤之處: 無 體會心得: 水題一定要認證

2018.3.28【 AtCoder beginner092-C 】解題報告線性處理

C - Traveling PlanTime limit : 2sec / Memory limit : 256MBScore : 300 pointsProblem StatementThere are N sightseeing spots on the x-axis,

杭電ACM hdu 2082 找單詞 解題報告母函式

Problem Description 假設有x1個字母A, x2個字母B,..... x26個字母Z,同時假設字母A的價值為1,字母B的價值為2,..... 字母Z的價值為26。那麼,對於給定的字母,可以找到多少價值<=50的單詞呢?單詞的價值就是組成一個單詞的所有

杭電ACM hdu 2079 選課時間 解題報告母函式

Problem Description 又到了選課的時間了,xhd看著選課表發呆,為了想讓下一學期好過點,他想知道學n個學分共有多少組合。你來幫幫他吧。(xhd認為一樣學分的課沒區別)Input輸入資料的第一行是一個數據T,表示有T組資料。每組資料的第一行是兩個整數n(1

Teams 解題報告組合數學

Problem E Teams Input: Standard Input Output: Standard Output In a galaxy far far away there is an ancient game played among the planet

【LeetCode】101. Symmetric Tree 解題報告Java & Python

目錄題目描述題目大意解題方法DFSBFS日期 [LeetCode] Total Accepted: 106639 Total Submissions: 313969 Difficulty: Easy 題目描述 Given a binary tree, ch