1. 程式人生 > >PAT甲級 1105 Spiral Matrix (25 分)模擬

PAT甲級 1105 Spiral Matrix (25 分)模擬

1105 Spiral Matrix (25 分)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has mrows and n columns, where m and n satisfy the following: m×n must be equal to N; m≥n; and m−n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 10​4​​. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

12
37 76 20 98 76 42 53 95 60 81 58 93

Sample Output:

98 95 93
42 37 81
53 20 76
58 60 76

題目大意: 給出數矩,求出符合要求的行和列,並按照要求打印出矩陣。

參考了這篇部落格,感覺邏輯處理上很清晰易懂:https://blog.csdn.net/a1eafall/article/details/51074712
首先要求出矩陣的行和列,行要大於等於列。 
對陣列進行排序。 
建立一個矩陣陣列,用於儲存矩陣結果。 
設四個變數minR,maxR,minC,maxC,用於記錄當前需要填充的行列的邊界。 
填充方法按題目所述,設定當前行列,nowR,nowC,從左至右,從上到下,從右到左,從下到上進行填充。並更新行列邊界值。
 

#include <iostream>
#include <algorithm>
#include <vector>
#include <cmath>
using namespace std;


int fun(int n){
	int i=sqrt(n); 
	while(i>=1){
		if(n%i==0)
			return i;
		i--;
	}
	return 1;
}

int main(){
	int n,a,b;
	cin>>n;
	a = fun(n);b = n/a;
	int row = max(a,b);
	int col = min(a,b);
	vector<int> vec(n);
	for(int i=0;i<n;i++){
		cin>>vec[i];
	}
	sort(begin(vec),end(vec));
	int arr[101][101] = {0};
	
	int index = n-1;
	int minR = 0,maxR = row-1,minC = 0,maxC = col-1;
	while(index>=0){
		for(int row=minR,col=minC;col<=maxC;col++)
			arr[row][col] = vec[index--];
		minR++;
		if(index < 0)//注意當陣列值沒有時,直接跳出迴圈 
			break; 
		for(int row=minR,col=maxC;row<=maxR;row++)
			arr[row][col] = vec[index--];
		maxC--;
		if(index < 0)
			break;
		for(int row=maxR,col=maxC;col>=minC;col--)
			arr[row][col] = vec[index--];
		maxR--;
		if(index < 0)
			break;
		for(int row=maxR,col=minC;row>=minR;row--)
			arr[row][col] = vec[index--];
		minC++;
		if(index < 0)
			break;
	}
	for(int i=0;i<row;i++){
		for(int j=0;j<col;j++){
			cout<<arr[i][j];
			if(j != col-1)
				cout<<" ";
		}
		cout<<endl;
	}
	
	return 0;
}