1. 程式人生 > >1151 LCA in a Binary Tree (30 分)【最小公共祖先】

1151 LCA in a Binary Tree (30 分)【最小公共祖先】

1151 LCA in a Binary Tree (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

Given any two nodes in a binary tree, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the binary tree, respectively. In each of the following two lines, N distinct integers are given as the inorder and preorder traversal sequences of the binary tree, respectively. It is guaranteed that the binary tree can be uniquely determined by the input sequences. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int

.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the binary tree, print in a line ERROR: U is not found.

 or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
7 2 3 4 6 5 1 8
5 3 7 2 6 4 8 1
2 6
8 1
7 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 6 is 3.
8 is an ancestor of 1.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

題意:找出最小的公共祖先,不存在的節點輸出不存在。

解題思路:可以將題目轉化成甲級題目1143。我們知道二叉搜尋樹的公共祖先是在中間,所以我們也可以弄成二叉搜尋樹,就是用下標處理。二叉搜尋樹的中序是按照從小到大排序,所以我們將二叉搜尋樹的下標從1開始標記到n,然後將pre也弄成下標,下標這樣處理就基本上可以按照1143做了,具體的見程式碼。(不過這裡只有29分,還差一分,在第三個測試點出現段錯誤,希望看到的朋友幫忙指點一下) 

#include<iostream>
#include<cstdio>
#include<vector>
#include<map>
using namespace std;

map<int,bool>mapp;

int main(void)
{
	int m,n;
	int in[10010];
	scanf("%d%d",&m,&n);
	vector<int>invalue(n+1),prevalue(n+1),pre(n+1);
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&invalue[i]);
		in[invalue[i]]=i;
	}
	for(int i=1;i<=n;i++)
	{
		scanf("%d",&prevalue[i]);
		mapp[prevalue[i]]=true;
		pre[i]=in[prevalue[i]];
	}
	int a;
	for(int i=0;i<m;i++)
	{
		int u,v,u1,v1;
		scanf("%d %d",&u,&v);
		u1=in[u],v1=in[v];
		for(int j=1;j<=n;j++)
		{
			a=pre[j];
			if(a>=u1&&a<=v1||a>=v1&&a<=u1) break;
		}
		if(mapp[u]==false&&mapp[v]==false)
		printf("ERROR: %d and %d are not found.\n",u,v);
		else if(mapp[u]==true&&mapp[v]==false)
		printf("ERROR: %d is not found.\n",v);
		else if(mapp[u]==false&&mapp[v]==true)
		printf("ERROR: %d is not found.\n",u);
		else if(a==u1||a==v1)
		printf("%d is an ancestor of %d.\n",invalue[a],a==u1?v:u);
		else  printf("LCA of %d and %d is %d.\n",u,v,invalue[a]);
	}
	return 0;
}