1. 程式人生 > >Java-SDUT1250 迴文串判定

Java-SDUT1250 迴文串判定

迴文串判定

Time Limit: 1000 ms Memory Limit: 65536 KiB

Submit Statistic

Problem Description

輸入一串字元(長度小於100),判斷該串字元是否是迴文串(正序讀與逆序讀內容相同)。

Input

輸入一串字元(長度小於100)。

Output

若該串字元是迴文串輸出“yes",否則輸出”no“。

Sample Input

asdfgfdsa

Sample Output

yes

Hint

Source

ACcode:

 

import java.util.*;

public class Main {

	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		String s1;
		s1 = in.nextLine();
		int i = 0, j = s1.length() - 1;
		int flag = 0;
		while (true) {
			if (s1.charAt(i) != s1.charAt(j)) {  // charAt.()方法 字串索引
				flag = 1;
				break;
			} else {
				i++;
				j--;
				if (i >= j)
					break;
			}
		}
		if (flag == 0)
			System.out.println("yes");
		else
			System.out.println("no");
	}
}