1. 程式人生 > >PAT甲級--1004 Counting Leaves(30 分)【層次遍歷+dfs】

PAT甲級--1004 Counting Leaves(30 分)【層次遍歷+dfs】

1004 Counting Leaves(30 分)

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01

is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1

 題意:給一棵樹,數每一層葉子節點的數量,最多100個節點,n代表總共n個節點,m代表mge非葉子節點,m是2位數,1表示為01,k表示這個節點有幾個孩子。

解題思路:用vector來儲存,輸入的m行中每一行都在同一層,通過這個來解決這題就顯得比較簡單了,通過v[a[front]].size()==0來判斷是不是葉子節點,用陣列a儲存每一層的孩子,維持一下判斷的順序就好了。

#include<iostream>
#include<cstdio>
#include<vector>
using namespace std;
vector<int>v[100];
int a[100];
int main(void)
{
	int n,m;
	scanf("%d%d",&n,&m);
	for(int i=0;i<m;i++)
	{
		int x,y;
		scanf("%d%d",&x,&y);
		for(int j=0;j<y;j++)
		{
			int z;
			scanf("%d",&z);
			v[x].push_back(z);
		}
	}
	int first=1;
	a[0]=1;
	int front=0,rear=1;
	while(front<rear)
	{
		int tag=rear;
		int cnt=0;
		while(front<tag)
		{
			int i=0;
			if(v[a[front]].size()==0) cnt++;//判斷葉子節點
			else
			{
				while(v[a[front]][i])
			    {
			    	a[rear++]=v[a[front]][i];
			    	i++;
				}
			}
                        //cout<<endl;
                        //cout<<front<<" "<<tag<<" "<<rear<<endl;
			front++;
		}
		if(first) first=0;//控制輸出格式
		else cout<<" ";
		cout<<cnt;
    } 
    cout<<endl;
	return 0;
}

dfs:這裡用的是鄰接表儲存,當size()==0,就說明是葉子結點,就返回,在返回之前我們要統計出最大深度,因為我們要將每一層的葉子結點數輸出來;然後如果是同一層且是葉子結點就在當層加1。

#include<bits/stdc++.h>
using namespace std;
vector<int>v[100];
int maxdepth=-1;
int cnt[101];
bool visit[101];
void dfs(int root,int depth)
{
	visit[root]=true;
	if(v[root].size()==0)
	{
		cnt[depth]++;
		maxdepth=max(depth,maxdepth);
		return;
	}
	
	for(int i=0;i<v[root].size();i++)
	{
		if(visit[v[root][i]]==false)
		dfs(v[root][i],depth+1);
	}
}
int main(void)
{
	int n,m,a,k,c;
	scanf("%d%d",&n,&m);
	for(int i=0;i<m;i++)
	{
		scanf("%d%d",&a,&k);
		for(int j=0;j<k;j++)
		{
			scanf("%d",&c);
			v[a].push_back(c);
		}
	}
	dfs(1,0);
	for(int i=0;i<=maxdepth;i++)
	{
		printf("%d",cnt[i]);
		if(i!=maxdepth) printf(" ");
	}
	return 0;
 }