1. 程式人生 > >HDOJ 題目3074 Multiply game(線段樹單點更新,區間求乘積)

HDOJ 題目3074 Multiply game(線段樹單點更新,區間求乘積)

Multiply game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2109    Accepted Submission(s): 748


Problem Description Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
  To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…


Input The first line is the number of case T (T<=10).
  For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an,
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n)
1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are no larger than 1 million.

Output For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.
Sample Input 1 6 1 2 4 5 6 3 3 0 2 5 1 3 7 0 2 5
Sample Output 240 420
Source
Recommend lcy   |   We have carefully selected several similar problems for you:  
3069
 3070 3071 3072 3073  一遍敲完,一遍過的感覺就是爽。。叫我水水題專業戶~~  ac程式碼
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define mod 1000000007
#define max(a,b) (a>b?a:b)
#define min(a,b) (a>b?b:a)
#define LL __int64
#define N 50050
LL node[N<<3];
void pushup(int tr)
{
	node[tr]=(node[tr<<1]*node[tr<<1|1])%mod;
}
void build(int l,int r,int tr)
{
	if(l==r)
	{
		LL x;
		scanf("%I64d",&x);
		node[tr]=x%mod;
		return;
	}
	int mid=(l+r)>>1;
	build(l,mid,tr<<1);
	build(mid+1,r,tr<<1|1);
	pushup(tr);
}
void update(int pos,int l,int r,LL val,int tr)
{
	if(l==r)
	{
		node[tr]=val%mod;
		return;
	}
	int mid=(l+r)>>1;
	if(pos<=mid)
		update(pos,l,mid,val,tr<<1);
	else
		update(pos,mid+1,r,val,tr<<1|1);
	pushup(tr);
}
LL query(int L,int R,int l,int r,int tr)
{
	if(L<=l&&r<=R)
	{
		return node[tr]%mod;
	}
	int mid=(l+r)>>1;
	LL a,b;
	a=b=1;
	if(L<=mid)
		a=query(L,R,l,mid,tr<<1);
	if(R>mid)
		b=query(L,R,mid+1,r,tr<<1|1);
	pushup(tr);
	return (a*b)%mod;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		int n;
		scanf("%d",&n);
		int i;
		build(1,n,1);
		int m;
		scanf("%d",&m);
		while(m--)
		{
			int op,a,b;
			scanf("%d%d%d",&op,&a,&b);
			if(op==0)
			{
				printf("%I64d\n",query(a,b,1,n,1)%mod);
			}
			else
				update(a,1,n,b,1);
		}
	}
}