1. 程式人生 > >HDU-2473 Junk-Mail Filter(並查集刪除節點)

HDU-2473 Junk-Mail Filter(並查集刪除節點)

Problem Description

Recognizing junk mails is a tough task. The method used here consists of two steps:

    1) Extract the common characteristics from the incoming email.

    2) Use a filter matching the set of common characteristics extracted to determine whether the email is a spam.

We want to extract the set of common characteristics from the N sample junk emails available at the moment, and thus having a handy data-analyzing tool would be helpful. The tool should support the following kinds of operations:

    a) “M X Y”, meaning that we think that the characteristics of spam X and Y are the same. Note that the relationship defined here is transitive, so relationships (other than the one between X and Y) need to be created if they are not present at the moment.

    b) “S X”, meaning that we think spam X had been misidentified. Your tool should remove all relationships that spam X has when this command is received; after that, spam X will become an isolated node in the relationship graph.

Initially no relationships exist between any pair of the junk emails, so the number of distinct characteristics at that time is N.

Please help us keep track of any necessary information to solve our problem.

Input

There are multiple test cases in the input file.

Each test case starts with two integers, N and M (1 ≤ N ≤ 10, 1 ≤ M ≤ 10), the number of email samples and the number of operations. M lines follow, each line is one of the two formats described above.

Two successive test cases are separated by a blank line. A case with N = 0 and M = 0 indicates the end of the input file, and should not be processed by your program.

Output

For each test case, please print a single integer, the number of distinct common characteristics, to the console. Follow the format as indicated in the sample below.

Sample Input

5 6 M 0 1 M 1 2 M 1 3 S 1 M 1 2 S 3 3 1 M 1 2 0 0 

Sample Output

Case #1: 3

Case #2: 2

由於在合併操作中所有點都會因路經壓縮而連結到根節點上,所以可以將每一個點都設立一個虛擬父節點,這樣根節點就是我們設立的虛擬節點,如果刪除某點,那麼可以修改當前節點的父節點來導致當前點的孤立,這樣就完成了刪點 。

#include<bits/stdc++.h>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
typedef long long ll;
const int maxn=1200000;
int father[N],vis[N];
int cnt;
int Find(int x)
{
    if(x!=father[x])
        return father[x] = Find(father[x]);
    return x;
}
void Union(int x, int y)
{
    x=Find(x);
    y=Find(y);
    if(x!=y) father[y]=x;
}
void del(int x) //刪除
{
    father[x]=cnt;
    cnt++;
}
int main ()
{
    int n,m;
    int k=1;
    while(scanf("%d%d",&n,&m)!=EOF&&(n||m))
    {
        cnt=n+n;
        for(int i=0;i<n;i++)//新增虛擬父節點
            father[i]=i+n;
        for(int i=n;i<=n+n+m;i++)//最多可刪除m個節點
            father[i]=i;
        while(m--)
        {
            int a,b,c;
            char ch[2];
            scanf("%s",&ch);
            if(ch[0]=='M')//合併
            {
                scanf("%d%d",&a,&b);
                Union(a,b);
            }
            else//刪除
            {
                scanf("%d",&c);
                del(c);
            }
        }
        int sum=0;
        memset(vis,0,sizeof(vis));
        for(int i=0;i<n;i++)//列舉所有點,檢視是否還在集合內
        {
            int x=Find(i);
            if(vis[x]==0)//若某點不在集合中
            {
                sum++;
                vis[x]=1;
            }
        }
        printf("Case #%d: %d\n",k++,sum);
    }
    return 0;
}