1. 程式人生 > >大量級階乘 - HDU-2674 N!Again

大量級階乘 - HDU-2674 N!Again

 NAgain

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6338    Accepted Submission(s): 3325


Problem Description

WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!

Input

Each line will contain one integer N(0 <= N<=10^9). Process to end of file.

 

Output

For each case, output N! mod 2009

 

Sample Input

4

5

 

Sample Output

24

120


 

 類似這種階乘,一定有特殊資料,試一下就能找到。

2009=7*7*41=49*41

也就是說,當n≥49時,n!一定是2009的倍數

#include <iostream>
#include <stdio.h>
using namespace std;

int main() {
	long long n;
	while(scanf("%lld",&n)!=EOF){
		long long res=1;
		if(n>=41)
		cout<<0<<endl;
		else{
		  for(int i=1;i<=n;i++){
			res=(res*i)%2009;
		}
		cout<<res<<endl;
		}
	}
	return 0;
}