1. 程式人生 > >HDU1035 Robot Motion(dfs)

HDU1035 Robot Motion(dfs)

題目連結

Robot Motion

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 13841    Accepted Submission(s): 6462  

Problem Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are  N north (up the page) S south (down the page) E east (to the right on the page) W west (to the left on the page) For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5

NEESWE

WWWESS

SNWWWW

4 5 1

SESWE

EESNW

NWEEN

EWSEN

0 0

Sample Output

10 step(s) to exit

3 step(s) before a loop of 8 step(s)

navigate 英[ˈnævɪgeɪt] 美[ˈnævɪˌɡet] vt.駕駛; 航行於; 使通過; vi. 航行; 駕駛;

結果又兩種情況,要麼退出,要麼陷入迴圈。

 如果能退出則直接輸出步數;如果陷入迴圈,則記錄下開始迴圈的行和列再進行一次搜尋。

AC程式碼:

#include<iostream>
#include<sstream>
#include<algorithm>
#include<string>
#include<cstring>
#include<iomanip>
#include<vector>
#include<cmath>
#include<ctime>
#include<stack>
#include<queue>
using namespace std;
int r,c,n,si,sj;
char map[11][11];
bool visited[11][11];
bool flag=0;//是否成功退出
int step=0;
void dfs(int i,int j,int s)
{
	if(i<1||i>r||j<1||j>c)//可以退出
	{
		flag=1;step=s;return;
	}
	else if(visited[i][j])//陷入迴圈 
	{
		si=i;sj=j;step=s;return;//記錄下開始陷入迴圈的行和列 
	}
	visited[i][j]=1;
	if(map[i][j]=='N') dfs(i-1,j,s+1);//向上走
	else if(map[i][j]=='S') dfs(i+1,j,s+1);//向下走
	else if(map[i][j]=='E') dfs(i,j+1,s+1);//向右走
	else if(map[i][j]=='W') dfs(i,j-1,s+1);//向下走 
}
int main()
{
	while(cin>>r>>c&&r!=0)
	{
		cin>>n;
		memset(visited,0,sizeof(visited));
		for(int i=1;i<=r;i++) cin>>map[i]+1;
		
		dfs(1,n,0);//從第一行的第n列開始搜尋,步數開始為0 
		if(flag) cout<<step<<" step(s) to exit\n";
		else 
		{
			int loop=step;
			step=0;
			memset(visited,0,sizeof(visited));
			dfs(si,sj,0);//再深搜一遍測出迴圈的步數step 
			cout<<loop-step<<" step(s) before a loop of "<<step<<" step(s)\n";
		}
		flag=0;
		step=0;
	}
}