1. 程式人生 > >A Spy in the Metro (dp)

A Spy in the Metro (dp)

A Spy in the Metro

 

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After several thrilling events we find her in the first station of Algorithms City Metro, examining the time table. The Algorithms City Metro consists of a single line with trains running both ways, so its time table is not complicated.

Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria knows that a powerful organization is after her. She also knows that while waiting at a station, she is at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running trains as much as possible, even if this means traveling backward and forward. Maria needs to know a schedule with minimal waiting time at the stations that gets her to the last station in time for her appointment. You must write a program that finds the total waiting time in a best schedule for Maria.

The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains move in both directions: from the first station to the last station and from the last station back to the first station. The time required for a train to travel between two consecutive stations is fixed since all trains move at the same speed. Trains make a very short stop at each station, which you can ignore for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the trains involved stop in that station at the same time.

Input

The input file contains several test cases. Each test case consists of seven lines with information as follows.

Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations.

Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment.

Line 3. N − 1 integers: t1, t2, . . . , tN−1 (1 ≤ ti ≤ 20), representing the travel times for the trains between two consecutive stations: t1 represents the travel time between the first two stations, t2the time between the second and the third station, and so on.

Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the first station.

Line 5. M1 integers: d1, d2, . . . , dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which trains depart from the first station.

Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th station.

Line 7. M2 integers: e1, e2, . . . , eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which trains depart from the N-th station.

The last case is followed by a line containing a single zero.

Output

For each test case, print a line containing the case number (starting with 1) and an integer representing the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is unable to make the appointment. Use the format of the sample output.

Sample Input

4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17 0

Sample Output

Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible

 

題意  某城市的地鐵有n個車站 編號1到n  有m1輛車向右開 給出m1個從車站1出發的時間  m2輛車向左開  給出m2個從車站n出發的時間  t[i]為火車從第i個車站開到第i+1(或相反)個車站需要的時間   Maria在車站1 她需要恰在時刻T到達第n個車站  求她的最小總車站等待時間

//#include"bits/stdc++.h"
//#include<unordered_map>
//#include<unordered_set>
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<set>
#include<vector>
#include<bitset>
#include<climits>
#include<queue>
#include<iomanip>
#include<cmath>
#include<stack>
#include<map>
#include<time.h>
using namespace std;
#define LL long long
#define ULL unsigned long long
#define MT(a,b) memset(a,b,sizeof(a))
const int INF  =  0x3f3f3f3f;
const int O    =  5e4;
const int mod  =  1e9+7;
const int maxn =  1e3+5;
const double PI  =  acos(-1.0);
const double E   =  2.718281828459;



int main(){
    int n, cas=0;
    while(~scanf("%d", &n) && n){
        int t; scanf("%d", &t);
        int l[100], r[100], a[100];
        for(int i=1; i<n; i++) scanf("%d", &a[i]);
        int lnum ; scanf("%d", &lnum);
        for(int i=0; i<lnum; i++) scanf("%d", &l[i]);
        int rnum ; scanf("%d", &rnum);
        for(int i=0; i<rnum; i++) scanf("%d", &r[i]);
        
        set<int>setl[100]; set<int>setr[100];
        int suml = 0, sumr = 0;
        for(int i=1; i<=n; i++){
            for(int j=0; j<lnum; j++){
                setl[i].insert(suml+l[j]);
            }
            suml += a[i];
        }
        for(int i=n; i>=1; i--){
            for(int j=0; j<rnum; j++){
                setr[i].insert(sumr+r[j]);
            }
            sumr += a[i-1];
        }
        
        int dp[maxn][100]; MT(dp, INF);//dp[i][j]表示時間為i在第j個車站的最小等待時間
        dp[0][1] = 0;
        for(int i=1; i<=t; i++){
            for(int j=1; j<=n; j++){
                if(dp[i-1][j] != INF) dp[i][j] = dp[i-1][j] + 1;
                if(setl[j].count(i) && i-a[j-1] >= 0 && dp[i-a[j-1]][j-1] != INF){
                    dp[i][j] = min(dp[i][j], dp[i-a[j-1]][j-1]);
                }
                if(setr[j].count(i) && i-a[j] >= 0 && dp[i-a[j]][j+1] != INF){
                    dp[i][j] = min(dp[i][j], dp[i-a[j]][j+1]);
                }
            }
        }
        
        printf("Case Number %d: ", ++ cas);
        dp[t][n] == INF ? printf("impossible\n"): printf("%d\n", dp[t][n]);
    }
    return 0;
}