1. 程式人生 > >HDU2594 (kmp,求兩字串的前後綴相同長度最大,水題)

HDU2594 (kmp,求兩字串的前後綴相同長度最大,水題)

 

 

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had. 
Marge: Yeah, what is it? 
Homer: Take me for example. I want to find out if I have a talent in politics, OK? 
Marge: OK. 
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix 
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton 
Marge: Why on earth choose the longest prefix that is a suffix??? 
Homer: Well, our talents are deeply hidden within ourselves, Marge. 
Marge: So how close are you? 
Homer: 0! 
Marge: I’m not surprised. 
Homer: But you know, you must have some real math talent hidden deep in you. 
Marge: How come? 
Homer: Riemann and Marjorie gives 3!!! 
Marge: Who the heck is Riemann? 
Homer: Never mind. 
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0. 
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton
homer
riemann
marjorie

Sample Output

0
rie 3

題意:

給你兩個字串,讓你求一個字串 這個字串滿足是第二個字串的字尾,且是第一個字串的字首,找出滿足情況的最長的字串

思路:

1.可以將兩個字串連線起來 用next陣列的意義來做,找出最後下標的最大匹配即可

2.利用kmp的意義,如果第二個字串的前j個字元的最大匹配為k,那麼即為j-1的字串的最大匹配且第j個字元與匹配的第k個字元相等即可.

//第二種方法
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=5e4+7;
int net[maxn],res[maxn];
char p[maxn],str[maxn];
void get_next(char *p,int *net)
{
    int lp=strlen(p);
    int j=0,k=-1;
    net[0]=-1;
    net[++j]=++k;
    while(j<lp)
    {
        if(k==-1||p[j]==p[k])
        {
            net[++j]=++k;
        }
        else
            k=net[k];
    }
}
void Solve(char *p,char *str)//指標str的字尾是其p的字首
{
    int i=0,k=0;
    get_next(p,net);
    int ls=strlen(str);
    // res[j]=k代表str前j個字元的最大匹配個數為k(字串s的前k個)
    while(i<ls)
    {
        if(k==-1||str[i]==p[k])//i k表示 正在匹配的字元
        {
            ++i;
            ++k;
            res[i]=k;
        }
        else
            k=net[k];
    }
    int ans=res[ls];
    if(!ans)
        printf("0\n");
    else
    {
        p[ans]='\0';
        printf("%s %d\n",p,ans);
    }
}
int main()
{
    while(~scanf("%s %s",p,str))
    {
        Solve(p,str);
    }
}