1. 程式人生 > >HDU1698 Just a Hook 區間更新,查詢區間【線段樹】

HDU1698 Just a Hook 區間更新,查詢區間【線段樹】

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15129    Accepted Submission(s): 7506

Problem Description

In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
 


Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.

Output

For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

Sample Input

1

10

2

1 5 2

5 9 3

Sample Output

Case 1: The total value of the hook is 24.

Source

2008 “Sunline Cup” National Invitational Contest

Recommend

wangye   |   We have carefully selected several similar problems for you:  1542 1394 2795 1255 1828 

題意:

有一條長度為N的金屬鏈,初始每一塊的值為1,然後是Q個操作,每個操作把【L,R】區間內的值變為X,求這條金屬鏈的權值和?

分析:

與點更新不同的是,這是對某一個區間的值進行更新;線段樹每一個節點代表一個區間,節點中儲存的值代表金屬的成色,1-銅,2-銀,3-金;如果這個區間有雜色金屬,則值為-1 

#include <iostream>
#include <cstdio>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
const int maxn = (1e5+10);

struct node{
	int left,right,n;
};
node tree[maxn<<2];

//初始化線段樹
void build(int rt,int l,int r){
    tree[rt].left=l;
    tree[rt].right=r;
    tree[rt].n=1;
    if(l==r){//遞迴出口,即當前節點為葉子節點
        return;
    }
    int mid=(tree[rt].left+tree[rt].right)>>1;
    build(rt<<1,l,mid);//遞迴初始化當前節點的左兒子
    build(rt<<1|1,mid+1,r);//遞迴初始化當前節點的右兒子
}

//從根節點開始更新,在區間[l,r]插入X
void update(int rt,int l,int r,int x){
    if(tree[rt].n==x)
        return;//顏色相同,直接返回
    if(tree[rt].left==l&&tree[rt].right==r){//插入的區間匹配,直接修改該區間的值
        tree[rt].n=x;
        return;
    }
    if(tree[rt].n!=-1){//是純色
        tree[rt<<1].n=tree[rt<<1|1].n=tree[rt].n;
        tree[rt].n=-1;
    }
    int mid=(tree[rt].left+tree[rt].right)>>1;
    if(r<=mid)//更新區間在中點的左邊,更新左子樹
        update(rt<<1,l,r,x);
    else if(l>mid)//更新區間在中點的右邊,更新右子樹
        update(rt<<1|1,l,r,x);
    else{//更新區間包含中點,同時更新左右子樹
        update(rt<<1,l,mid,x);
        update(rt<<1|1,mid+1,r,x);
    }
}
//查詢區間[L,R]的和
int query(int rt,int l,int r){
    if(tree[rt].n==-1)//雜色
       return query(rt<<1,l,r)+query(rt<<1|1,l,r);
    else
        return (tree[rt].right-tree[rt].left+1)*tree[rt].n;
}
int main()
{
    int T;
    scanf("%d",&T);
    int ca=1;
    while(T--){
        int n,q;
        scanf("%d%d",&n,&q);
        build(1,1,n);
        while(q--){
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            update(1,x,y,z);
        }
        int ans=query(1,1,n);
        printf("Case %d: The total value of the hook is %d.\n",ca++,ans);
    }
}