1. 程式人生 > >#153-[揹包DP]手鍊

#153-[揹包DP]手鍊

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

有N(1 ≤ N ≤ 3,402) 件物品和一個容量為V的揹包。第i件物品的重量是w[i](1 ≤ Wi ≤ 400),價值是d[i](1 ≤ Di ≤ 100)。求解將哪些物品裝入揹包可使這些物品的重量總和不超過揹包容量M(1 ≤ M ≤ 12,880),且價值總和最大。

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

第一行:物品個數N和揹包大小M

第二行至第N+1行:第i個物品的重量w[i]和價值d[i]

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

輸出一行最大價值。

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23
// 一道水題

#include <iostream>

#define SIZE 13010

using namespace std;

int dp[SIZE];

int main(void)
{
	int t, n, i, w, c;
	
	scanf("%d%d", &n, &t);
	while (n--)
	{
		scanf("%d%d", &w, &c);
		for (i = t; i >= w; --i)
		{
			dp[i] = max(dp[i], dp[i-w] + c); // 條件轉移方程
		}
	}
	
	printf("%d", dp[t]);
	
	return 0;
}