1. 程式人生 > >1039 Course List for Student (25)

1039 Course List for Student (25)

rom con mat next sin 段錯誤 with one student

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i

, first the course index i and the number of registered students N~i~ (<= 200) are given in a line. Then in the next line, N~i~ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student‘s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

牛客網出錯的測試點:

33 2
2 23
AAB2 AAA8 AAD1 AAC8 AAB6 AAA1 AAA9 AAA6 AAB1 AAA3 AAD2 AAC4 AAC3 AAB4 AAB5 AAD3 AAB7 AAB9 AAA0 AAC7 AAC9 AAC0 AAC1
1 3
AAB6 AAA1 AAC4 AAA0 AAA1 AAA2 AAA3 AAA4 AAA5 AAA6 AAA7 AAA8 AAA9 AAB0 AAB1 AAB2 AAB3 AAB4 AAB5 AAB6 AAB7 AAB8 AAB9 AAC0 AAC1 AAC2 AAC3 AAC4 AAC5 AAC6 AAC7 AAC8 AAC9 AAD0 AAD1 AAD2

#include<stdio.h>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn = 26 * 26 * 26 * 10 + 1;
vector<int> student[maxn];

int change(char name[]) {
    int id = 0;
    for (int i = 0; i < 3; i++) {
        id = id * 26 + (name[i] - A);   //沒有進行“*26”[智障] 會運行超時和答案錯誤
    }
    id = id * 10 + (name[3] - 0);  //修改時沒有去掉等號前的加號“+=”導致段錯誤
    return id;
}

int main() {
    int N, K;  //N為學生人數, K為課程數
    char name[5];
    scanf("%d%d", &N, &K);
    for (int i = 0; i < K; i++) {
        int course_num, num;
        scanf("%d%d", &course_num, &num);
        for (int j = 0; j < num; j++) {
            scanf("%s", name);
            int id = change(name);
            student[id].push_back(course_num);
        }
    }
    for (int i = 0; i < N; i++) {
        scanf("%s", name);
        int id = change(name);
        printf("%s %d", name, student[id].size());
        sort(student[id].begin(), student[id].end());
        for (int j = 0; j < student[id].size(); j++) {
            printf(" %d", student[id][j]);
        }
        printf("\n");
    }
    return 0;
}



1039 Course List for Student (25)