1. 程式人生 > >浙江省第十二屆省賽 Beauty of Array

浙江省第十二屆省賽 Beauty of Array

multipl ber tin war 隊列 which contain 計算 bits

Description

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer T

indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

題意:

定義Beauty數是一個序列裏所有不相同的數的和,求一個序列所有字序列的Beauty和

題解:

按先後順序將每個元素加入隊列 然後計算

例:如果array【1,2,3】

1: 1 dp = 1;

2: 1 2

2 dp = 1+2*2;

3: 1 2 3

   2 3

    3   dp = 5+3*3;

以此類推,如果有相同元素 emmmmm 自己去推吧 -.-

代碼:

#include <bits/stdc++.h>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <vector>
#include <map>
#include <set>
#include <bitset>
#include <queue>
#include <deque>
#include <stack>
#include <iomanip>
#include <cstdlib>
#include <string>
using namespace std;
#define is_lower(c) (c>=‘a‘ && c<=‘z‘)
#define is_upper(c) (c>=‘A‘ && c<=‘Z‘)
#define is_alpha(c) (is_lower(c) || is_upper(c))
#define is_digit(c) (c>=‘0‘ && c<=‘9‘)
#define min(a,b) ((a)<(b)?(a):(b))
#define max(a,b) ((a)>(b)?(a):(b))
#define IO ios::sync_with_stdio(0);\
    cin.tie(0);    cout.tie(0);
#define For(i,a,b) for(int i = a; i <= b; i++)
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> pii;
typedef pair<ll,ll> pll;
typedef vector<int> vi;
const ll inf=0x3f3f3f3f;
const double EPS=1e-10;
const ll inf_ll=(ll)1e18;
const ll maxn=100005LL;
const ll mod=1000000007LL;
const int N = 1000000+5;
int ans [N];int main()
{
    IO
    int T;
    cin>>T;
    while(T--)
    {
        int n;
        memset(ans,0,sizeof(ans));
        cin>>n;
        int m = 0;
        ll res = 0,dp = 0;
        For(i,1,n){
            int x;
            cin>>x;
                dp += x*(i-ans[x]);
            res += dp;
            ans[x] = i;
        }
        cout<<res<<endl;
    }
    return 0;
}

浙江省第十二屆省賽 Beauty of Array