1. 程式人生 > >hdu 6191--Query on A Tree(持久化字典樹)

hdu 6191--Query on A Tree(持久化字典樹)

out trie scribe nodes include mathjax osi lan push_back

題目鏈接

Problem Description Monkey A lives on a tree, he always plays on this tree.

One day, monkey A learned about one of the bit-operations, xor. He was keen of this interesting operation and wanted to practise it at once.

Monkey A gave a value to each node on the tree. And he was curious about a problem.

The problem is how large the xor result of number x and one node value of label y can be, when giving you a non-negative integer x and a node label u indicates that node y is in the subtree whose root is u(y can be equal to u).

Can you help him?

Input There are no more than 6 test cases.

For each test case there are two positive integers n and q, indicate that the tree has n nodes and you need to answer q queries.

Then two lines follow.

The first line contains n non-negative integers V1,V2,?,Vn, indicating the value of node i.

The second line contains n-1 non-negative integers F1,F2,?Fn1, Fi means the father of node i+1.

And then q lines follow.

In the i-th line, there are two integers u and x, indicating that the node you pick should be in the subtree of u, and x has been described in the problem.

2n,q105

0Vi109

1Fin, the root of the tree is node 1.

1un,0x109

Output For each query, just print an integer in a line indicating the largest result.

Sample Input 2 2 1 2 1 1 3 2 1

Sample Output 2 3 題意:有一棵由n個節點構成的樹,每個點上有一個權值,現在q次詢問,每次輸入u,x 表示以u為根節點的子樹上 以某個節點上的權值異或x得到的最大值? 思路:持久化 trie 樹,感覺和主席樹差不多,是有 n 個版本的字典樹,在遍歷樹的過程中經過點時,建立新的字典樹,但實際上與舊的相比每次只是增加了log2(1e9)個節點,另外是在子樹 u 上求最大異或值,所以需要保存 u 子樹之前節點號和 u 子樹中的最後一個節點的編號,作差即可得到相應的數據; 代碼如下:
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
const int N=1e5+5;
int a[N];
struct Node
{
    int son[2];
    int sum[2];
}node[35*N];
vector<int>G[N];
int la[N],to[N],root[N];
int tot1,tot2;

void init()
{
   node[0].son[0]=node[0].son[1]=0;
   node[0].sum[0]=node[0].sum[1]=0;
   root[0]=0;
   tot1=tot2=0;
   for(int i=1;i<N;i++) G[i].clear();
}
void build(int pre,int now,int x,int deep)
{
    if(deep<0) return ;
    int tmp=!!(x&(1<<deep));
    node[now]=node[pre];
    node[now].sum[tmp]++;
    build(node[pre].son[tmp],node[now].son[tmp]=++tot2,x,deep-1);
}
void dfs(int now)
{
    la[now]=++tot1;
    build(root[la[now]-1],root[la[now]]=++tot2,a[now],30);
    for(int i=0;i<G[now].size();i++)
    {
        int v=G[now][i];
        dfs(v);
    }
    to[now]=tot1;
}
int query(int pre,int now,int sum,int x,int deep)
{
    if(deep<0) return sum;
    int tmp=!!(x&(1<<deep));
    if(node[now].sum[tmp^1]>node[pre].sum[tmp^1])
        return query(node[pre].son[tmp^1],node[now].son[tmp^1],sum|(1<<deep),x,deep-1);
    return query(node[pre].son[tmp],node[now].son[tmp],sum,x,deep-1);
}
int main()
{
    int n,q;
    while(scanf("%d%d",&n,&q)!=EOF)
    {
        init();
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        for(int i=2;i<=n;i++)
        {
            int x; scanf("%d",&x);
            G[x].push_back(i);
        }
        dfs(1);
        while(q--)
        {
            int u,x; scanf("%d%d",&u,&x);
            printf("%d\n",query(root[la[u]-1],root[to[u]],0,x,30));
        }
    }
    return 0;
}

hdu 6191--Query on A Tree(持久化字典樹)