1. 程式人生 > >HDU5437 Alisha’s Party(優先隊列+模擬)

HDU5437 Alisha’s Party(優先隊列+模擬)

top 1.7 acm iss left over .cn ide 每次

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others) Total Submission(s): 4075 Accepted Submission(s): 1052

Problem Description Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value
v技術分享, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p技術分享 people enter her castle. If there are less than
p技術分享 people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query
n技術分享 Please tell Alisha who the n?th技術分享 person to enter her castle is.

Input The first line of the input gives the number of test cases, T技術分享 , where 1T15技術分享.

In each test case, the first line contains three numbers k,m技術分享 and q技術分享 separated by blanks. k技術分享 is the number of her friends invited where 1k150,000技術分享. The door would open m times before all Alisha’s friends arrive where 0mk技術分享. Alisha will have q技術分享 queries where 1q100技術分享.

The i?th技術分享 of the following k技術分享 lines gives a string B技術分享i技術分享技術分享, which consists of no more than 200技術分享 English characters, and an integer v技術分享i技術分享技術分享, 1v技術分享i技術分享10技術分享8技術分享技術分享, separated by a blank. B技術分享i技術分享技術分享 is the name of the i?th技術分享 person coming to Alisha’s party and Bi brings a gift of value v技術分享i技術分享技術分享.

Each of the following m技術分享 lines contains two integers t(1tk)技術分享 and p(0pk)技術分享 separated by a blank. The door will open right after the t?th技術分享 person arrives, and Alisha will let p技術分享 friends enter her castle.

The last line of each test case will contain q技術分享 numbers n技術分享1技術分享,...,n技術分享q技術分享技術分享 separated by a space, which means Alisha wants to know who are the n技術分享1技術分享?th,...,n技術分享q技術分享?th技術分享 friends to enter her castle.

Note: there will be at most two test cases containing n>10000技術分享.

Output For each test case, output the corresponding name of Alisha’s query, separated by a space.
Sample Input
1
5 2 3
Sorey 3
Rose 3
Maltran  3
Lailah 5
Mikleo  6
1 1
4 2
1 2 3

Sample Output
Sorey Lailah Rose

Source 2015 ACM/ICPC Asia Regional Changchun Online
題意:有k個人帶著價值vi的礼物來,開m次門,每次在有t個人來的時候開門放進來p個人。全部人都來了之後再開一次門把剩下的人都放進來。每次帶礼物價值高的人先進,價值同樣先來先進。q次詢問,詢問第n個進來的人的名字。
分析:優先隊列+模擬就能夠了,僅僅是註意m能夠為0。
<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a,b) memset(a,b,sizeof(a))
#define lson (i<<1)
#define rson ((i<<1)|1)
#define MAXN 150010

struct node
{
    int id,v;
    char name[220];
    bool operator < (const node &tmp) const
    {
        if(v == tmp.v) return id < tmp.id;
        return v > tmp.v;
    }
}p[MAXN];

struct opendoor
{
    int a,b;
    bool operator < (const opendoor &tmp) const
    {
        return a < tmp.a;
    }
}od[MAXN];

set<node> s;
int query[110];

int main()
{
    int T,n,m,q;
    scanf("%d",&T);
    while(T--)
    {
        s.clear();
        scanf("%d%d%d",&n,&m,&q);
        for(int i=1; i<=n; i++)
        {
            scanf("%s %d",p[i].name, &p[i].v);
            p[i].id = i;
        }
        for(int i=0; i<m; i++)
            scanf("%d%d",&od[i].a, &od[i].b);
        sort(od, od+m);
        int maxq;
        for(int i=0; i<q; i++)
        {
            scanf("%d",&query[i]);
            maxq = max(maxq, query[i]);
        }
        vector <int> ans;
        int cnt = 0;
        for(int i=1; i<=n&&ans.size()<maxq; i++)
        {
            s.insert(p[i]);
            while(od[cnt].a==i && cnt<m)
            {
                for(int j=0; j<od[cnt].b&&!s.empty()&&ans.size()<maxq; j++)
                {
                    ans.push_back(s.begin()->id);
                    s.erase(s.begin());
                }
                cnt++;
            }
        }
        while(!s.empty() && ans.size()<maxq)
        {
            ans.push_back(s.begin()->id);
            s.erase(s.begin());
        }
        for(int i=0; i<q; i++)
        {
            if(i) printf(" ");
            cout<<p[ans[query[i]-1]].name;
        }
        puts("");
    }
    return 0;
}
</span>


HDU5437 Alisha’s Party(優先隊列+模擬)