線段樹查詢最大值以及查詢區間和
I Hate It
Time Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 94892 Accepted Submission(s): 35915
Problem Description
很多學校流行一種比較的習慣。老師們很喜歡詢問,從某某到某某當中,分數最高的是多少。
這讓很多學生很反感。
不管你喜不喜歡,現在需要你做的是,就是按照老師的要求,寫一個程式,模擬老師的詢問。當然,老師有時候需要更新某位同學的成績。
Input
本題目包含多組測試,請處理到檔案結束。
在每個測試的第一行,有兩個正整數 N 和 M ( 0<N<=200000,0<M<5000 ),分別代表學生的數目和操作的數目。
學生ID編號分別從1編到N。
第二行包含N個整數,代表這N個學生的初始成績,其中第i個數代表ID為i的學生的成績。
接下來有M行。每一行有一個字元 C (只取'Q'或'U') ,和兩個正整數A,B。
當C為'Q'的時候,表示這是一條詢問操作,它詢問ID從A到B(包括A,B)的學生當中,成績最高的是多少。
當C為'U'的時候,表示這是一條更新操作,要求把ID為A的學生的成績更改為B。
Output
對於每一次詢問操作,在一行裡面輸出最高成績。
Sample Input
5 61 2 3 4 5Q 1 5U 3 6Q 3 4Q 4 5U 2 9Q 1 5
Sample Output
565
查詢最大值程式碼:
#include<iostream>
#include<cstring>
# define MAXN 2000005
int maxx;
using namespace std;
struct node
{
int left;
int right;
int value;
} q[MAXN];
int father[MAXN];
void BuildTree(int i,int l,int r)
{
q[i].left=l;
q[i].right=r;
q[i].value=0;
if(l==r)
{
father[l]=i;
return ;
}
BuildTree(i<<1,l,(l+r)/2);
BuildTree((i<<1)+1,(l+r)/2+1,r);
}
void UpdateTree(int ri)
{
if(ri==1)
{
return ;
}
int fi=ri/2;
int a=q[fi*2].value;
int b=q[fi*2+1].value;
q[ri/2].value=max(a,b);
UpdateTree(ri/2);
}
void FindMax(int i,int l,int r)
{
if(q[i].left==l&&q[i].right==r)
{
maxx=max(maxx,q[i].value);
return ;
}
i=i<<1;
if(l<=q[i].right)
{
if(r<=q[i].right)
{
FindMax(i,l,r);
}
else if(r>q[i].right)
{
FindMax(i,l,q[i].right);
}
}
i++;
if(r>=q[i].left)
{
if(l>=q[i].left)
{
FindMax(i,l,r);
}
else
FindMax(i,q[i].left,r);
}
}
int main()
{
int n,m;
ios::sync_with_stdio(false);
while(cin>>n>>m)
{
BuildTree(1,1,n);
for(int i=1; i<=n; i++)
{
int temp;
cin>>temp;
q[father[i]].value=temp;
UpdateTree(father[i]);
}
while(m--)
{
char str;
int u,v;
cin>>str>>u>>v;
if(str=='Q')
{
maxx=0;
FindMax(1,u,v);
cout<<maxx<<endl;
}
else
{
q[father[u]].value=v;
UpdateTree(father[u]);
}
}
}
return 0;
}
查詢區間和程式碼:
#include<iostream>
#include<cstring>
# define MAXN 2000005
int maxx;
int res;
using namespace std;
struct node
{
int left;
int right;
int value;
} q[MAXN];
int father[MAXN];
void BuildTree(int i,int l,int r)
{
q[i].left=l;
q[i].right=r;
q[i].value=0;
if(l==r)
{
father[l]=i;
return ;
}
BuildTree(i<<1,l,(l+r)/2);
BuildTree((i<<1)+1,(l+r)/2+1,r);
}
void UpdateTree(int ri)
{
if(ri==1)
{
return ;
}
int fi=ri/2;
int a=q[fi*2].value;
int b=q[fi*2+1].value;
q[ri/2].value=a+b;
UpdateTree(ri/2);
}
void Query(int i,int l,int r)
{
if(q[i].left==l&&q[i].right==r)
{
res+=q[i].value;
// maxx=max(maxx,q[i].value);
return ;
}
i=i<<1;
if(l<=q[i].right)
{
if(r<=q[i].right)
{
Query(i,l,r);
}
else
{
Query(i,l,q[i].right);
}
}
i++;
if(r>=q[i].left)
{
if(l>=q[i].left)
{
Query(i,l,r);
}
else
Query(i,q[i].left,r);
}
}
int main()
{
int n,m;
ios::sync_with_stdio(false);
while(cin>>n>>m)
{
BuildTree(1,1,n);
for(int i=1; i<=n; i++)
{
int temp;
cin>>temp;
q[father[i]].value=temp;
UpdateTree(father[i]);
}
while(m--)
{
res=0;
char str[100];
int u,v;
cin>>str>>u>>v;
if(str[0]=='Q')
{
Query(1,u,v);
cout<<res<<endl;
}
else
{
q[father[u]].value+=v;
UpdateTree(father[u]);
}
}
}
return 0;
}